IS SItecore CMS 7.2 is compatible with MVC 4/5 ?

- Pranay on Okt 30 '14
- viewed 1309 times

I have installed visual studio 2012(supporting MVC4 and .NET 4.5) and Sitecore CMS 7.2 rev.140526. I am able to run the Sitecore using admin user and launch the website too.

I was going through this tutorial on MVC integration with Sitecore which creates an MVC application in visual studio and then integrates in the Sitecore CMS site. When I followed the same steps I got error. The MVC version used in this tutorial is MVC3 and the Sitecore version is 7.1. I have tried the same in my machine but got the error Could not load file or assembly 'System.Web.Mvc, Version=5.1.0.0.

From the error I understand that it is looking for MVC 5.1 but in my machine I have only MVC4. Will Sitecore 7.1 support MVC 5.1?

if it supports only MVC 5.1. Is there any work around to run Sitecore with MVC 5 or lesser versions.


Your Comments






You might also like

1. Populating Sitecore mvc model in .net mvc view

2. How to create a new login user in Sitecore and what are roles required for a content author?

3. Rendering parameters in Sitecore MVC and its implementation with an example

4. How to implement authentication using active directory in sitecore MVC 7.2?

5. Controller rendering in Sitecore MVC with a full example


SIGN UP AND GET LATEST UPDATES.

Recent Posts

×
 

Liked this article?

Subscribe with your email and get updates when ever a new article is posted.

By subscribing you agree to our privacy terms. We promise that we do not sell your data.